Packet Tracer

Realizzare il seguente schema di rete.

Configurare le interfacce Ethernet sui PC: assegnare gli indirizzi IP e specificare i gateway di default per ogni PC, facendo riferimento alla figura.

Configurare le interfacce seriali ed Ethernet dei router.

Verificare la configurazione inviando pacchetti ping da una stazione al suo gateway predefinito.

Verificare l'indirizzamento IP.

Usare il comando show ip interface brief per verificare che gli indirizzi sono corretti e le interfacce sono diventate attive. Al termine salvare la configurazione nella NVRAM del router.

Configurare RIP.

Abilitare l'instradamento dinamico.

Per abilitare il protocollo di instradamento dinamico occorre entrare in modalità configurazione globale ed usare il comando router. Se, al prompt, si scrive router ? si legge l'elenco dei protocolli di instradamento disponibili.

Per abilitare il RIP sul router0:

  1. clic sul router

  2. clic sulla scheda CLI

  3. Invio,

  4. router0>enable [invio]
    router0#
  5. router0#configure terminal [invio]
    router0(config)#
  6. inserire il comando router rip:

    router0(config)#router rip
    router0(config-router)#

Inserire gli indirizzi di rete.

Mentre ci si trova in modalità routing configuration mode, dare l'indirizzo di ciascuna rete direttamente connessa:

router0(config-router)#network 192.168.1.0
router0(config-router)#network 192.168.2.0
router0(config-router)#

Il comando network:

Al termine ritornare in modalità privilegiata EXEC e salvare la configurazione nella NVRAM.

router0(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
router0#copy run start

Configurare RIP sul router router1 usando i comandi router rip e network.

router1>enable [invio]
router1#configure terminal [invio]
router1(config)#router rip
router1(config-router)#network 192.168.2.0
router1(config-router)#network 192.168.3.0
router1(config-router)#network 192.168.4.0
router1(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
router1#copy run start

Al termine si ritorna in modalità privilegiata EXEC e si salva la configurazione nella NVRAM.

Configurare RIP sul router router2.

router1>enable [invio]
router1#configure terminal [invio]
router2(config)#router rip
router2(config-router)#network 192.168.4.0
router2(config-router)#network 192.168.5.0
router2(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
router2# copy run start

Al termine si ritorna in modalità privilegiata EXEC e si salva la configurazione nella NVRAM.

Configurare la porta seriale.

Su router0

router0(config)#interface serial 0/0/0
router0(config-if)#ip address 192.168.2.253 255.255.255.0
router0(config-if)#clock rate 64000
router0(config-if)#bandwidth 64
router0(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
router0(config-if)#exit
router0(config)#

Su router1

router1(config)#interface serial 0/0/0
router1(config-if)#ip address 192.168.2.254 255.255.255.0
router1(config-if)#clock rate 64000
router1(config-if)#bandwidth 64
router1(config)#interface serial 0/0/1
router1(config-if)#ip address 192.168.4.254 255.255.255.0
router1(config-if)#clock rate 64000
router1(config-if)#bandwidth 64
router1(config-if)#no shutdown
router1(config-if)#exit

Su router2

router1(config)#interface serial 0/0/0
router1(config-if)#ip address 192.168.4.253 255.255.255.0
router1(config-if)#clock rate 64000
router1(config-if)#bandwidth 64
router1(config-if)#no shutdown
router1(config-if)#exit

Verificare l'instradamento RIP.

Verificare che ogni router ha tutte le reti nella tabella di instradamento.

Gli instradamenti appresi tramite il RIP sono codificati con R nella tabella di instradamento. Se l'algoritmo non è ancora giunto alla stabilità controllare la rete e correggere l'errore. Verificare che le interfacce siano attive. Verificare la corretta configurazione del RIP.

router0#show ip route
. . . Output omesso . . .
Gateway of last resort is not set
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Serial0/0/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:04, Serial0/0/0
R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:04, Serial0/0/0
R 192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:04, Serial0/0/0
router0#



router1#show ip route
. . . Output omitted . . .
R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:22, Serial0/0/0
C 192.168.2.0/24 is directly connected, Serial0/0/0
C 192.168.3.0/24 is directly connected, FastEthernet0/0
C 192.168.4.0/24 is directly connected, Serial0/0/1
R 192.168.5.0/24 [120/1] via 192.168.4.1, 00:00:23, Serial0/0/1
router1#



router2#show ip route
. . . Output omitted . . .
R 192.168.1.0/24 [120/2] via 192.168.4.2, 00:00:18, Serial0/0/1
R 192.168.2.0/24 [120/1] via 192.168.4.2, 00:00:18, Serial0/0/1
R 192.168.3.0/24 [120/1] via 192.168.4.2, 00:00:18, Serial0/0/1
C 192.168.4.0/24 is directly connected, Serial0/0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0
router2#

Usare il comando show ip protocols per leggere le informazioni del processo di instradamento.

Il commando show ip protocols mostra informazioni relative al processo di instradamento che avviene sul router. la risposta ottenuta consente di verificare i parametri RIP:

router0#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 16 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
InterfaceSendRecvTriggered RIPKey-chain
FastEthernet0/0121  
Serial0/0/0 1 2 1  
Automatic network summarization is in effect Maximum path: 4
Routing for Networks:
192.168.1.0
192.168.2.0

Passive Interface(s):
Routing Information Sources:
GatewayDistanceLast Update
192.168.2.2120 
Distance: (default is 120)
router0#

router0 è configurato con il RIP. router0 invia e riceve aggiornamenti RIP su FastEthernet0/0 e Serial0/0/0. router0 annuncia le reti 192.168.1.0 e 192.168.2.0. router0 ha una sorgente di informazioni di routing. router1 sta inviando gli aggiornamenti ad router0.

Leggere i messaggi RIP scambiati.

Gli aggiornamenti vengono inviati ogni 30 secondi, quindi potrebbe essere necessario aspettare prima di riuscire ad osservare le informazioni.

router0#debug ip rip
router0#RIP: received v1 update from 192.168.2.2 on Serial0/0/0
    192.168.3.0 in 1 hops
    192.168.4.0 in 1 hops
    192.168.5.0 in 2 hops
RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.1.1)
RIP: build update entries
    network 192.168.2.0 metric 1
    network 192.168.3.0 metric 2
    network 192.168.4.0 metric 2
    network 192.168.5.0 metric 3
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (192.168.2.1)
RIP: build update entries
    network 192.168.1.0 metric 1

L'output del debug mostra che router0 riceve un aggiornamento da router1. Notare che questo aggiornamento comprende tutte le reti che router0 non ha già nella sua tabella di instradamento. Siccome l'interfaccia FastEthernet0/0 appartiene alla rete 192.168.1.0 configurata con RIP, router0 prepara un aggiornamento da inviare a quella interfaccia.

L'aggiornamento include tutte le reti conosciute da router0 tranne la rete dell'interfaccia. Infine router0 prepara un aggiornamento da inviare a router1.

Fermare l'output del debug

router0#undebug all

Modifiche

Usando la stessa topologia della simulazione precedente, modificare gli indirizzi IP delle interfacce:

DispositivoInterfacciaIndirizzoIPSubnetMaskDefault Gateway
router0Fa0/0172.30.1.1255.255.255.0N/A
S0/0/0172.30.2.1255.255.255.0N/A
router1Fa0/0172.30.3.1255.255.255.0N/A
S0/0/0172.30.2.2255.255.255.0N/A
S0/0/1192.168.4.9255.255.255.0N/A
router2Fa0/0192.168.5.1255.255.255.0N/A
S0/0/1192.168.4.10255.255.255.0N/A
PC1NIC172.30.1.10255.255.255.0172.30.1.1
PC2NIC172.30.3.10255.255.255.0172.30.3.1
PC3NIC192.168.5.10255.255.255.0192.168.5.1

Modificare gli indirizzi IP delle interfacce come indicato nella tabella. Potrebbe succedere che, quando si cambia l'indirizzo di un'interfaccia seriale, sarà necessario riavviare l'interfaccia usando il comando shutdown, e aspettando che compaia il messaggio LINK-5-CHANGED, e poi dando il comando no shutdown. Questo processo forza il riavvio di IOS per usare il nuovo indirizzo IP.

router0(config)#int s0/0/0
router0(config-if)#ip add 172.30.2.1 255.255.255.0
router0(config-if)#shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to administratively down %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down router0(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
router0(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Verificare che i router siano attivi.

Dopo aver riconfigurato tutte le interfacce sui router, verificare che esse sono attive tramite il commando show ip interface brief.

Rimuovere la configurazione RIP dai router.

È preferibile rimuovere RIP e riavviare. Rimuovere le configurazioni RIP da ciascun router con il comando no router rip. Verranno rimosse le configurazioni RIP e i comandi network.

router0(config)#no router rip
router1(config)#no router rip
router2(config)#no router rip

Configurare RIP

Configurare l'instradamento RIP su router0.

router0(config)#router rip
router0(config-router)#network 172.30.0.0

Notare che basta una sola istruzione network per router0. Questa istruzione include entrambe le interfacce sulle sottoreti della rete 172.30.0.0.

Configurare router0 affinché cessi l'invio degli aggiornamenti su FastEthernet0/0.

L'invio dei pacchetti di aggiornamento rappresenta una inutile occupazione di banda e un impegno di risorse di calcolo. Inoltre la notifica in broadcast rappresenta un rischio per la sicurezza. Gli aggiornamenti RIP possono venire intercettati con un semplice software di sniffing. Gli aggiornamenti possono essere modificati e rispediti al router alterando le tabelle di instradamento con falsi valori di metrica allo scopo di forzare instradamenti errati.

Il commando passive-interface fastethernet 0/0 viene usato per disabilitare gli aggiornamenti RIPv1. Dopo aver completato la configurazione RIP, ritornare in modalità privilegiata EXEC e salvare la configurazione attuale nella NVRAM.

router0(config-router)#passive-interface fastethernet 0/0
router0(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
router0#copy run start

Configurare il RIP su router1.

router1(config)#router rip router1(config-router)#network 172.30.0.0 router1(config-router)#network 192.168.4.0 router1(config-router)#passive-interface fastethernet 0/0 router1(config-router)#end %SYS-5-CONFIG_I: Configured from console by console
router1#copy run start

Anche in questo caso basta un solo commando network per le due sottoreti 172.30.0.0. Questa istruzione include entrambe le interfacce sulle differenti sottoreti della rete principale 172.30.0.0. Adesso la rete sul lato WAN tra router1 ed router2 è configurata.

Al termine si torna in modo privilegiato EXEC e si salva la configurazione nella NVRAM.

Configurare l'instradamento RIP su router2.

router2(config)#router rip
router2(config-router)#network 192.168.4.0
router2(config-router)#network 192.168.5.0
router2(config-router)#passive-interface fastethernet 0/0
router2(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
router2#copy run start

Al termine si torna in modo privilegiato EXEC e si salva la configurazione nella NVRAM.

Verificare l'instradamento RIP

Con il comando show ip route su ciascun router verificare che le reti sono presenti nella tabella di instradamento.

router0#show ip route
. . . Output omitted . . .
172.30.0.0/24 is subnetted, 3 subnets
C 172.30.1.0 is directly connected, FastEthernet0/0
C 172.30.2.0 is directly connected, Serial0/0/0
R 172.30.3.0 [120/1] via 172.30.2.2, 00:00:22, Serial0/0/0
R 192.168.4.0/24 [120/1] via 172.30.2.2, 00:00:22, Serial0/0/0
R 192.168.5.0/24 [120/2] via 172.30.2.2, 00:00:22, Serial0/0/0
router0#

Nota: RIPv1 è un protocollo che non invia la subnet mask della rete con gli aggiornamenti. Per esempio, 172.30.1.0 è inviato da router1 a router0 senza alcuna informazione di subnet mask.

router1#show ip route
. . . Output omitted . . .
172.30.0.0/24 is subnetted, 3 subnets
R 172.30.1.0 [120/1] via 172.30.2.1, 00:00:04, Serial0/0/0
C 172.30.2.0 is directly connected, Serial0/0/0
C 172.30.3.0 is directly connected, FastEthernet0/0
192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.8 is directly connected, Serial0/0/1
R 192.168.5.0/24 [120/1] via 192.168.4.10, 00:00:19, Serial0/0/1
router1#


router2#show ip route
. . . Output omitted . . .
R 172.30.0.0/16 [120/1] via 192.168.4.9, 00:00:22, Serial0/0/1
192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.8 is directly connected, Serial0/0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0

Verificare che tutte le interfacce siano attive.

Se una o più tabelle di instradamento non convergono ad una configurazione stabile, assicurarsi che tutte le interfacce siano attive, con il comando show ip interface brief.

Poi usare show ip protocols per verificare la configurazione RIP. Notare nell'output di tale commando che l'interfaccia FastEthernet0/0 non compare nell'elenco "Interface" ma in una sezione "Passive Interface(s)".

router0#show ip protocols
Routing Protocol is "rip"
   Sending updates every 30 seconds, next due in 20 seconds
   Invalid after 180 seconds, hold down 180, flushed after 240
   Outgoing update filter list for all interfaces is not set
   Incoming update filter list for all interfaces is not set
   Redistributing: rip
   Default version control: send version 2, receive version 2
InterfaceSendRecvTriggered RIPKey-chain
Serial0/1/022  
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
   172.30.0.0
   209.165.200.0
Passive Interface(s):
   FastEthernet0/0

Routing Information Sources:
   Gateway Distance Last Update
   209.165.200.229 120 00:00:15
Distance: (default is 120)

Osservare i messaggi RIP inviati e ricevuti.

Per leggere i messaggi RIP usare il commando debug ip rip. Notare che gli aggiornamenti RIP non vengono inviati sulla passive-interface fastethernet 0/0.

router0#debug ip rip
router0#RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (172.30.2.1)
RIP: build update entries
network 172.30.1.0 metric 1
RIP: received v1 update from 172.30.2.2 on Serial0/0/0
172.30.3.0 in 1 hops

Interrompere il debugging

router0#undebug all

Tutti i possibili debugger vengono fermati.

Configurazione di Enhanced Interior Gateway Routing Protocol

EIGRP è il miglioramento di IGRP.

Interior Gateway Routing Protocol (IGRP)

L'Interior Gateway Routing Protocol (IGRP) è un protocollo del livello Rete di tipo distance vector.

IGRP genera gli aggiornamenti per ricalcolare la tabella di instradamento ogni 90 secondi. il periodo hold-down è 280 secondi, e il periodo di flush è 630 secondi.

IGRP richiede un numero di AS (Autonomous System) nei comandi del router; inoltre, quando si deve specificare un indirizzo di rete bisogna darlo in notazione completa.

Enhanced Interior Gateway Routing Protocol

Le caratteristiche dell'Enhanced Interior Gateway Routing Protocol (EIGRP) sono:

Se in una rete sono presenti router che eseguono IGRP ed altri che eseguono EIGRP ed entrambi hanno lo stesso numero di autonomous system, le informazioni di instradamento saranno condivise tra i due.

I router EIGRP diventano vicini se valgono le seguenti condizioni:

Quando due router diventano vicini svolgono le seguenti azioni:

Bisogna specificare il numero AS quando si configura EIGRP. Anche se EIGRP usa lo schema di indirizzi, bisogna specificare l'indirizzo di rete con il comando network.

clic sull'icona del router ed aprire la scheda CLI.

Router 0:

Per configurare ed abilitare l'instradamento EIGRP su router0:

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname router0
router0(config)#interface fastethernet 0/0
router0(config-if)#ip address 10.0.0.1 255.0.0.0
router0(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
router0(config-if)#exit
router0(config)#interface serial 0/0/0
router0(config-if)#ip address 20.0.0.1 255.0.0.0
router0(config-if)#clock rate 64000
router0(config-if)#bandwidth 64
router0(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
router0(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
router0(config)#router eigrp 1
router0(config-router)#network 10.0.0.0
router0(config-router)#network 20.0.0.0
router0(config-router)#exit
router0(config)#

Router 1:

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname router1
router1(config)#interface serial 0/0
router1(config-if)#ip address 20.0.0.2 255.0.0.0
router1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
router1(config-if)#exit
router1(config)#interface fastethernet 0/0
router1(config-if)#ip address 30.0.0.1 255.0.0.0
router1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
router1(config-if)#exit
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
router1(config)#router eigrp 1
router1(config-router)#network 20.0.0.0
router1(config-router)#network 30.0.0.0
router1(config-router)#exit
router1(config)#

Router 3:

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname router2
router2(config)#interface fastethernet 0/0
router2(config-if)#ip address 30.0.0.2 255.0.0.0
router2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
router2(config-if)#interface serial 0/0
router2(config-if)#ip address 40.0.0.1 255.0.0.0
router2(config-if)#clock rate 64000
router2(config-if)#bandwidth 64
router2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to down
router2(config-if)#exit
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
router2(config)#router eigrp 1
router2(config-router)#network 30.0.0.0
router2(config-router)#network 40.0.0.0
router2(config-router)#exit
router2(config)#

Router 4:

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 40.0.0.2 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config-if)#exit
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 50.0.0.1 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
router2(config)#router eigrp 1
router2(config-router)#network 30.0.0.0
router2(config-router)#network 40.0.0.0
router2(config-router)#exit
router2(config)#

PC-1

PC>ipconfig

IP Address......................: 10.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 10.0.0.1

PC>ping 50.0.0.2

PC-2

PC>ipconfig
IP Address......................: 50.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 50.0.0.1

PC>ping 10.0.0.2

Per verificare che EIGRP sia in esecuzione usare il comando show ip protocols in privilege mode.

R4#show ip protocols

Routing Protocol is "ospf 4"
   Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
   Router ID 50.0.0.1
   Number of areas in this router is 1. 1 normal 0 stub 0 nssa
   Maximum path: 4
   Routing for Networks:
     50.0.0.0 0.255.255.255 area 0
     40.0.0.0 0.255.255.255 area 0
   Routing Information Sources:
     Gateway Distance Last Update
     40.0.0.1 110 00:01:26
   Distance: (default is 110)
R4#

Usare show ip route per individuare malfunzionamenti in EIGRP. Se manca qualche riga nella tabella di instradamento controllare il router connesso a quella rete.

R4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
     E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
     * - candidate default, U - per-user static route, o - ODR
     P - periodic downloaded static route

Gateway of last resort is not set

O    10.0.0.0/8 [110/1564] via 40.0.0.1, 00:02:37, Serial0/0/0
O    20.0.0.0/8 [110/1563] via 40.0.0.1, 00:02:37, Serial0/0/0
O    30.0.0.0/8 [110/782] via 40.0.0.1, 00:02:37, Serial0/0/0
C    40.0.0.0/8 is directly connected, Serial0/0/0
C    50.0.0.0/8 is directly connected, FastEthernet0/0
R4#

Per verificare l'instradamento EIGRP eseguire ping da pc1 a pc2 e viceversa. Se la risposta non arriva bisogna rivedere la configurazione.